Menus

 

The menu consists of

 

File Menu

Edit Menu

Compute Menu

Help Menu

 

 

File Menu

 

New

Creates a new project and sets all values to default value.  The values in the current project are not saved and it doesn’t prompt to save the existing values. 

 

Open

Opens a file-chooser dialog to select an existing ‘.gem’ (geotechnical engineering model) project file to load.   The values in the current project are not saved and it doesn’t prompt the user to save the data. 

 

 

Save

Saves the existing project to the ‘.gem’ file.  If a file is not already specified, it opens the file-chooser dialog to select the name of the file to be saved.  The project properties and input parameters are saved into the file. 

 

Save As

Opens a file-chooser to select the file to save the project to. 

 

Export to Excel

Exports the project properties, input parameters, Analysis to an excel (.xlsx) file. 

  It first opens a file-chooser dialog to select the export file. 

 

To avoid stale analysis values being exported, rerun the analysis using the compute menu and then export the contents to excel.

 

Note that Analysis results are exported for Analysis models having FULL / SUBSCRIPTION license.  Analysis models with trial licenses are not exported. 

 

Export to Word

Exports the project properties, input parameters, Analysis to a MS Word (.docx) file. 

  It first opens a file-chooser dialog to select the export file. 

 

To avoid stale analysis values being exported, rerun the analysis using the compute menu and then export the contents to word document.

 

Note that Analysis results are exported for Analysis models having FULL / SUBSCRIPTION license.  Analysis models with trial licenses are not exported. 

 

Print

Opens a print dialog to print report to the printer.

 

 

Select the printer from the selection list.

Select the number of copies to be printed.

Click on print to print the document.

 

The application can print only to a pdf capable printer. This functionality is not available on the cloud.  The document will be rendered like the ‘export to word’ document. 

 

To avoid stale analysis values being printed, rerun the analysis using the compute menu and then print the document.

 

Note that Analysis results are printed for Analysis models having "FULL" or "SUBSCRIPTION" licenses.  Analysis models with trial licenses are not printed. 

 

Preferences

Preferences are global preferences that are loaded at the start of the application.  These can be overridden with project specific values. 

 

 

User Directory

This is the default directory where all project files will be stored.  Click on the folder icon to select the directory.  It will display a directory chooser dialog.  The selection is displayed to the left of the folder icon

 

Units

The default units for the application can be set here.  The choices include ‘SI Units’ and ‘Commonly American units’.  These are then applied to all future projects. 

 

Save

Save button saves the preferences for the application.

 

Cancel

Cancel button exits the preference dialog box without saving the changes. 

 

 

Edit Menu

 

Cut

Cuts the current selection into the clipboard. 

 

Copy

Copies the current selection into the clipboard. 

 

Paste

Pastes the current selection from the clipboard.

 

Delete

Deletes the current selection. 

 

Compute Menu

 

Validate

Validate checks all the inputs for errors.  If there are no errors, a notification indicating the same is displayed. 

 

 

If there are errors, you will get notifications detailing each error. 

 

 

Troubleshooting errors

 

Fill all the required parameters in the ‘Input Parameters’ pane and complete all the required tables.  The mandatory fields have a red star () adjacent to the field.

 

Project Properties Pane

1.     Analysis Model (at least one model should be selected)

 

Input Parameters Pane

1.     Beam Length

2.     Elastic modulus of beam

3.     Breadth table

4.     Depth table

5.     Soil properties tab

a.     Elastic Modulus of soil – if ‘Elastic Half-space analysis model’ is selected

b.     Poisson ratio of soil – if ‘Elastic Half-space analysis model’ is selected

 

c.     Subgrade Modulus Table – if ‘Discrete Spring Bed Analysis model’ is selected

 

6.     Data in the load case tabs.  If no data is specified, it will assume that no load is applied on the beam. 

 

Tables with errors will highlighted with a red border with a label indicating ‘error’.  Hovering the mouse over the ‘error’ label indicates the nature of error.

 

Graphical user interface, application

Description automatically generated

 

Incomplete tables will have a label at the bottom right-hand corner indicating ‘info reqd.’. Hovering the mouse over the ‘info reqd.’ label indicates the nature of the information required. 

 

A picture containing table

Description automatically generated

 

Clear Outputs

 

Clears all the output tables and graphs.  This will clear all the tables and graphs in the ‘Discrete spring bed analysis’ pane, ‘Elastic Half-space Analysis’ pane.

 

Compute

 

Selecting the compute performs the analysis based on the parameters provided.

 

The application first validates the inputs.  If inputs are not valid, it displays the errors and doesn’t proceed further.  Refer to ‘validate Inputs’ for more details on trouble shooting errors. 

 

If Inputs are valid, it proceeds to perform the analysis.  

 

A successful analysis will pop up a notification for each analysis model selected for analysis. 

 

 

The respective analysis panes will also be highlighted in green color to indicate that fresh results are available.  Click on the panes to view the analysis. 

 

 

 

 

If there are errors while performing the execution, or the execution takes more than 5 seconds to perform, the execution will error out with appropriate errors. 

 

Help Menu

 

License

 

License menu pops up a license dialog indicating the current status of the license. 

 

There are two analysis modules which are licensed

 

Discrete Spring Bed Analysis

Elastic Half-space Analysis

 

License information during trial period

 

 

Product Key

This is only applicable for desktop applications running on Windows / macOS and is not applicable for applications hosted on GEMS cloud.  This is the product key for the license once you purchase any module.  This field is editable if there is no product key associated with this application.  Once a product key is applied and the application activated, they ‘Product Key’ field cannot be edited.  The product key is tied to the machine once it is activated on the machine.  Uninstalling the application will not remove the association of the product key with this machine.  The product key can be disassociated after deactivating the license key by clicking the deactivate button. 

 

Name

Name of the licensee to whom the product key is issued to.  This field is populated by the application by downloading this information from the internet servers.  This information is provided by the user at the time of purchase of the license.

 

Organization

Name of the organization to which the licensee belongs to.  This field is populated by the application by downloading this information from the internet servers.  This information is provided by the user at the time of purchase of the license.

 

License Type

Type of license for the analysis module. The values can be

 

TRIAL – This module can be used under trial license.  The functionality of this module may be limited during the trial period.  Trial period is typically 30 days from the date the application is installed on the machine.   Internet connectivity is required to use the application if both modules are under trial. The application validates the trial license with our servers on the internet each time it is launched. 

 

EXTENDED_TRIAL – This module can be used under trial license.  The functionality of this module may be limited during the extended trial period.  The license is valid for the extended trial period shown. Internet connectivity is required to use the application if all the modules are under extended trial. The application validates the trial license with our servers on the internet each time it is launched. 

 

SUBSCRIPTION – This module has a subscription license and there are no restrictions in functionality.  The license period is for the period shown and requires renewal prior to the expiry date.  One is advised to renew the license before the expiry date to avoid any discontinuity.  Please contact support@gemsoftware.org or visit www.gemsoftware.org/purchase to renew the subscription.  The application validates the license periodically with our servers for validity. 

 

FULL – This module has a full license and there are no restrictions in functionality.  The license period is permanent & perpetual.  The application validates the license with our servers periodically for validity. 

 

EXPIRED – The license period has expired.  Please contact support@gemsoftware.org or visit www.gemsoftware.org/purchase to purchase license for this module.  Click on ‘revalidate’ if you feel that the license may still be valid.  The application cannot be used if all licenses are in INVALID / EXPIRED / UNKNOWN state.

 

INVALID/UNKNOWN – The state of the license cannot be.  This may happen if the application cannot validate license information against our servers on the internet.  Click on ‘Revalidate Button’ to contact our servers on the internet to get updated information. When the application is first installed, the initial state may be “INVALID / UNKNOWN / TRIAL”. 

 

The application cannot be used if all the licenses are in INVALID / EXPIRED / UNKNOWN state.

 

 

Validity

This field gives the validity of each of the license.

 

License related messages are displayed in the messages area. 

 

 

Activate Button

Activate button is used to activate the product key.  Enter the product key and click on the ‘Activate’ button to activate the key.  Once the product key is activated, it gives a notification indicating the same. 

 

Deactivate Button

Deactivate button de-activates the product key associated with this machine. The ‘Deactivate Button’ is only visible when a valid product key has been activated on the machine.   The license key can now be used on another machine.  When uninstalling the software from the machine, remember to deactivate the software first. 

 

Re-Validate Button

Revalidate button is used to revalidate the product key and license types with our servers.  When the user purchases additional licenses, updates license features, click on the revalidate button to fetch updated license information from our servers.

 

Close Button

Closes the license dialog.  If all the licenses are EXPIRED/INVALID/UNKNOWN then the application will also close.  The application can only be used if the correct product key is entered and at least one license is of TRIAL / EXTENDED_TRIAL / SUBSCRIPTION / FULL type.

 

Graphical user interface, application

Description automatically generated

 

License information after SUBSCRIPTION license is activation.

 

 

About

 

About menu displays information regarding the application, copyright information and has links to “License” for this software. 

 

Help

 

Displays help related information for the application